La función SI en Excel - ?· La función SI en Excel La función SI en Excel es parte del grupo de…

  • Published on
    07-Dec-2018

  • View
    212

  • Download
    0

Transcript

La funcin SI en Excel

La funcin SI en Excel es parte del grupo de funciones Lgicas y nos permite evaluar una condicin para determinar si es falsa o verdadera. La funcin SI es de gran ayuda para tomar decisiones en base al resultado obtenido en la prueba lgica.

Sintaxis de la funcin SIAdems de especificar la prueba lgica para la funcin SI tambin podemos especificar valores a devolver de acuerdo al

resultado de la funcin.

Prueba_lgica (obligatorio): Expresin lgica que ser evaluada para conocer si el resultado es VERDADERO o FALSO.

Valor_si_verdadero (opcional): El valor que se devolver en caso de que el resultado de la Prueba_lgica sea VERDADERO.

Valor_si_falso (opcional): El valor que se devolver si el resultado de la evaluacin es FALSO.

La Prueba_lgica puede ser una expresin que utilice cualquier operador lgico o tambin puede ser una funcin de Excel que regrese como resultado VERDADERO o FALSO.Los argumentos Valor_si_verdadero y Valor_si_falso pueden ser cadenas de texto, nmeros, referencias a otra celda o inclusive otra funcin de Excel que se ejecutar de acuerdo al resultado de la Prueba_lgica.

Ejemplos de la funcin SI

Probaremos la funcin SI con el siguiente ejemplo. Tengo una lista de alumnos con sus calificaciones correspondientes en la columna B. Utilizando la funcin SI desplegar un mensaje de APROBADO si la calificacin del alumno es superior o igual a 60 y un mensaje de REPROBADO si la calificacin es menor a 60. La funcin que utilizar ser la siguiente:

=SI(B2>=60,"APROBADO","REPROBADO")

Observa el resultado al aplicar esta frmula en todas las celdas de la columna C.

Utilizar una funcin como prueba lgica

Es posible utilizar el resultado de otra funcin como la prueba lgica que necesita la funcin SI siempre y cuando esa otra funcin regrese como resultado VERDADERO o FALSO. Un ejemplo de este tipo de funcin es la funcin ESNUMERO la cual evala el contenido de una celda y devuelve el valor VERDADERO en caso de que sea un valor numrico. En este ejemplo quiero desplegar la leyenda SI en caso de que la celda de la columna A efectivamente tenga un nmero, de lo contrario se mostrar la leyenda NO.

=SI(ESNUMERO(A2), "SI", "NO")

Este es el resultado de aplicar la frmula sobre los datos de la hoja:

Utilizar una funcin como valor de regreso

Como ltimo ejemplo mostrar que es posible utilizar una funcin para especificar el valor de regreso. Utilizando como base el ejemplo anterior, necesito que en caso de que la celda de la columna A contenga un valor numrico se le sume el valor que colocar en la celda D1. La funcin que me ayudar a realizar esta operacin es la siguiente:

=SI(ESNUMERO(A2), SUMA(A2, $D$1), "NO")

Como puedes observar, el segundo argumento es una funcin la cual se ejecutar en caso de que la prueba lgica sea verdadera. Observa el resultado de esta frmula:

Slo en los casos donde la funcin SI era verdadera se realiz la suma. De la misma manera podramos colocar una funcin para el tercer argumento en caso de que el resultado de la prueba lgica fuera falso.